Microsoft Backpedals on SP3 Y2K-Compliance

<P>Microsoft recently announced that SP3 is not fully compliant, and changed SP3’s status to &quot;compliant, with minor issues.&quot;</P>

When Service Pack 4 (SP4) was released, a stability concern scared some IT departments into delaying deployment. Microsoft Corp. had branded SP3 as Y2K compliant, so no immediate needs pressured wary companies to upgrade.

Microsoft, however, recently announced that SP3 is not fully compliant, and changed SP3’s status to "compliant, with minor issues." In turn, the company is now proclaiming that SP4 is the service pack for full Y2K compliance.

"We strongly recommend that users upgrade to SP4," says Don Jones, product manager, Year 2000, at Microsoft.

But the situation is not that simple. Andrew Diamondstein, associate analyst with market research firm Giga Information Group (, explains that some companies may want to hold off on SP4 for the time being.

"Companies that plan to implement SP4 but are considering waiting until after 2000 should install SP4 now," Diamondstein cautions. "But companies planning to go from SP3 straight to Windows 2000 may want to hold off on SP4 at least until Microsoft announces what the minor issues are with SP3."

Until Microsoft releases the list of minor issues, which will probably happen next month, there is no certainty about the risks of continuing to stick with SP3. Unless the issues are more serious than expected, core functionality, data integrity and system reliability should not be affected.

Among the 28 memory leak fixes, various patches and new features, SP4 includes more than 650 new bug fixes -- 15 of which are for Y2K compliance. Fixes are included for The User Manager and User Manager for Domains, which have leap year issues with 2000. The system clock now can be updated by a Date/Time applet, and Word document properties recognize both 1900 and 2000 as valid centuries and support four-digit years. DHCP also supports the years 2000 to 2009 with a minimum of two digits. Finally, Find Files supports only numeric character recognition in the decades field.

Installing the fourth Service Pack using Update.exe fixes all necessary files within Windows NT. SP4 also detects and exposes additional Microsoft components that require updating to resolve known Year 2000 issues.

"SP4 brings the entire OS environment to compliant status," Jones says.

The operating system, as well as all the option packs, service packs and downloads are compliant under SP4. There are more than forty core features, and with the packs and downloads, Windows NT can be configured more than 62,000 ways -- all of which need to be tested.

Making Windows NT compliant, however, does not make other Microsoft products that work in conjunction with the operating system Y2K-compliant. Several of the products that work with Windows NT, such as Microsoft Transaction Server 1.0 and FrontPage 97, still need to be updated for compliance.

In the meantime, Microsoft will not bring SP3 beyond its current status of compliant, with minor issues.

"We are committed to keeping SP3 at compliant with minor issues. We will continue to add fixes to SP3 as they arise, but only minor fixes," Jones says. "With SP4, we are guaranteeing to add whatever it takes to retain compliant status between now and January 1, 2001."

Despite the updates in SP4, the following features in Windows NT Server 4.0 still need to be repaired or upgraded. Here is how Microsoft recommends making them Y2K compliant:



Active Directory Services Interface 1.0

Install ADSI 2.0

Microsoft Virtual Machine

See Microsoft VM Y2K Guide

FrontPage 97 and Server Extensions

Install FrontPage 97 Year 2000 fixes

Internet Locator Service 1.0

Install Internet Locator Service 2.0

Microsoft Transaction Server 1.0

Install MTS 2.0 from Option Pack